This MindTouch Deki has expired; please contact your system administrator. Visit MindTouch.com for activation information.

Pre-Installation

 

Pre-Installation Requirements  

This page describes the environmental requirements you should verifybeforerunning the install program for Zmanda Management Console and Amanda Enterprise Server. The ZMC and Amanda Enterprise server components required on each are described inDownloading and Installing Amanda Enterprise Components  

Throughout this document, TheAmanda Clientrefers the system being backed up by theAmanda Enterprise Server using ZMC, which also called theAmanda Serverorbackup server and ZMC or UI Server respectively.   

·         Identify the hosts and filesystems to be protected using Amanda software.The list of hosts to be protected are the Amanda backup clients. The Amanda backup clients and the filesystems or directories to be backed up on each client will need to be specified during Amanda configuration.   

·         Identify the Amanda backup server.The Amanda backup server should have access to the media (tape, disk, changers) where the Amanda client backups will be stored on tapes or the backup process is managed (in case of NDMP). Any Amanda client can also act as an Amanda server, and it is recommended that every Amanda server also be a backup client. In selecting your ZMC and Amanda backup server machine, keep in mind that the server might use a significant amount of memory during backup runs, and that it must have good network connectivity to all Amanda clients.   

ZMC and Amanda Enterprise Server Requirements   

ZMC and Amanda Backup server performs various CPU, Memory, Network, and Disk intensive operations. While hardware requirements will vary based on your backup environment, we recommend a dedicated server or a virtual machine with at least 4GB of memory and a modern quad-core server-class CPU. The bandwidth of the network link between backup server and your network switch is also very critical. If network bonding is supported by your switch, we recommend providing a bonded connection to the backup server.   

·         You should have at least 2 GB of disk space on the disk where ZMC and Amanda Enterprise software is being installed.   

·         The ZMC, Amanda Backup server and clients must have the latest service packs or updates to the distribution installed.   

·         ZMC, Amanda Backup server and client cannot be installed on an NFS-mounted file systems. For example: You should not install the Amanda Enterprise ZMC (/opt/zmanda/amanda) on an NFS partition.   

·         In addition to the space required for the software itself, you should ensure that there is always 10% free space in the Zmanda installation and temporary directories, defined here. If ZMC or Amanda Enterprise server runs out of space on either of these directories while a backup is in progress, the backup will fail with MySQL errors. Also ZMCwill print warnings messages when there is insufficient disk space.   

·         Theamandabackupuser should have privileges to have crontab entries to perform scheduled backups. In some distributions, theamandabackupuser must be added tocron.allowfile. This file is usually in/etcor/etc/cron.ddirectory.   

·         Theamandabackupuser should have permissions to read and write to disk and tape devices (if they are used for backup). Theamandabackupuser is automatically added todiskuser group on Linux systems. It is important to restart ZMCand Backup server after adding amandabackup user to thetapeuser group.   

·          If you intend to back up an Oracle server, theamandabackupuser must have permission to write to the$ORACLE_HOMEdirectory.   

·         Theamandabackupuser should have permission to write to the/tmpdirectory on the Amanda Backup server.   

·         If a tape changer is the intended backup media, the backup server also requires both themt-standmtxpackage in addition to the platform-specific dependencies listed below. If a tape drive is the intended backup media,mtis required. Without the appropriate packages, ZMCwill return an error message when you try to view these devices.   

·          The directories/etc/amandaand/etc/zmandamust be on the same file system.   

·         Amanda clients must have open inbound TCP ports 10080 and 10081.   

·         Internal firewalls and selinux policy must not prevent PHP processes from using HTTP over the loopback address 127.0.0.1   

Package Dependencies 

The following packages are required on the Amanda backup server and clients: 

Linux 

Program Dependencies: The following programs are needed A reasonably supported current x86_64 Linux system (Debian or RedHat based, currently) for Linux backup server and client 

·     Basic Utilities/Libraries 

o   Bash >= 4.2,  Coreutils,  Gawk,  

o   Glibc >= 2.17, zlib >= 1.2.2 

o   Libgcc >= 4.8, Libstdc++ >= 4.8 

·     System Utilities: [Systemd required] 

o   Logrotate, Cronie or Cron with /usr/bin/crontab 

o   Systemd >= 219,  

o   Libselinux >= 2.3 (with SELinux not active) 

·     Required components 

o   GnuPG2,  

o   Libexpat >= 2.1 

o   Libmount >= 2.19 

o   GNUtar >= 1.23 

·     Important components (optional) 

o   Firewalld (preferred but configured w/tool) 

o   VMware Disklib >= 6.5, 

o   NFS mount functionality 

o   Mt (for tape operation), 

o   Smbclient (for CIFS disk access) 

o   Mailx or /bin/mail (for email notifications) 

o   BSDTar, Star (as needed) 

 

These packages are installed by default on most Linux distributions. If you need to add them, you can use yum or apt-get. Packages can be obtained from the distribution media or from a distribution repository (run either as root): 

#yum install package_name 

or 

#apt-get install package_name 

Package Dependencies   

The following packages are required on the Amanda clients:   

Linux (Client only)   

Download and install the client package available from theZmanda Network download pagewhen you select Linux as the client platform.   

See the The Zmanda Linux Client User's Manual for further details on Windows client installation.   

Windows (Server & Desktop) clients   

Theamandabackupuser must exist, and be added to theUsers,BackupOperators,andAdministratorsgroups. Windows clients must open inbound TCP ports 10080 and 10081, and outbound TCP ports 800:840. Windows application backups (licensed as separate agents) require that the Volume Shadow Copy Service be enabled and started. To prevent excessive memory consumption on application backup clients, Zmanda also recommends that you install the VSS hotfix from Microsoft. 

See the The Zmanda Windows Client User's Manualfor further details on Windows client installation.   

  

Post installation changes on Linux Amanda Clients   

·         This section is not applicable for Windows clients.   

·          Make sure there is a reverse name lookup record in the DNS for the Amanda server (FQDN if FQDNis used in the Amanda configuration files).   

·         The.amandahostsfile for theamandabackupuser (~amandabackup/.amandahosts) on the client must authorize the Amanda server to run a backup.   

·         The/etc/amanda/amanda-client.conffile must be edited on the client (if the client and server do not reside on the same machine). Specifically, the following entries must be edited: 

index_server "localhost"        # your amindexd server   

tape_server "localhost"        # your amidxtaped server   

Change"localhost"to match to the hostname of theAmanda backup server.   

·         If secure communication is required for restoration,sshmust be used for restoration.sshis also required when restoring to a MacOS X/Unix/Linux system that is not running the Zmanda Client software. To force the restore process to usessh, edit/etc/xinetd.d/zmrecoveron Linux systems to include the following line:   

disable = yes   

·         On MacOSX systems, run the following command:launchctl unload -w /Library/LaunchDaemons/org.amanda.zmrecover.plist. To re-enable the standard client restore mechanism, enter:launchctl load -w /Library/LaunchDaemons/org.amanda.zmrecover.plist  

Zmanda Management Console Browser Requirements   

The following browsers have been tested and verified to work with the Zmanda Management Console:   

·          Latest version of Chrome   

·          Latest version of Firefox   

·         Recent versions of other browsers may also work   

In all cases you must have JavaScript enabled. Note that if JavaScript is enabled during a session either in the browser itself or in a plug-in such as NoScript, you must log out of the ZMC and then log in again to avoid potential problems with the interface. If you are browsing over a slowconnection such as dial-up, loading of the JavaScript filesmay time out after 15 seconds.     

 

 
 

 

Powered by MindTouch Deki v.8.08.2